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Overview of TransBraille 
 

 TransBraille is a software package that helps teachers teach mathematics to blind 

students. This package is developed using image processing and special language 

translation techniques. The prime use of this software is to help sighted teachers teach 

mathematics to blind students. In just a few easy steps, the teacher can convert a Braille 

page typed by a blind student into “Print Form”, readable by sighted people thereby 

saving a lot of time for the teacher. 

   

 

 

Salient Features of the product :  

• Takes as input, a scanned copy of the Braille sheet hand typed on a Perkins 

Brailler and outputs a PDF file. 

• TransBraille can handle slanted typed lines as well as irregularly typed lines  

• Documents can contain Nemeth Code and Literary Braille. Nemeth Code 

expressions are automatically separated from contracted braille text  

• TransBraille also handles spatial math:  

o Determinants  

o Matrices  

o Grade school,  

� Addition  

� Subtraction  

� Multiplication  

� Long Division, etc.  

• Nemeth Code Syntax errors made by the student are detected and confined to the 

smallest possible area and rest of the document is  translated correctly  

• User has full control at every step and change / modify the document in any of the 

intermediate steps  

• User has the choice of either do step by step conversion or do direct conversion 
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1 Hardware requirements 
Disk Space:  

Memory: 128MB. (256MB recommended) 

CPU: Pentium III or faster 

Scanner:   300DPI resolution (recommended) or more 

Printer: Inkjet or Laser (recommended) 

2 Software requirements 
Operating System: Windows XP (All variants) or higher 

Adobe Acrobat Reader (Need to install this) 

MiKTeX (Aspell installer is a part of TransBraille package. Need to install this)  

ASpell (Aspell installer is a part of TransBraille package Need to install this) 

PROLOG (Software part of TransBraille package) 

3 Installing TransBraille 
� Put the CD of TransBraille  in CD ROM  

� Install ‘aspell’ from the CD.  

� Install ‘Miktex’ from the CD 

� Add “C:\Program Files\Aspell\bin” to your windows path  

� Now run the setup for TransBraille. 

�Follow the instructions of the installer. 

� It will navigate you and help you throughout your installation process. 

� When installation is finished you can see shortcut of TransBraille on your desktop 

as  

     well as it will create a folder “C:\Program Files\Logical Software Solutions”  

      where all the executables and supporting resources are copied  

4 Using TransBraille 

4.1 Scanning the Braille Page 

→ Scan the back side of the Braille page to avoid ink marks, if any, on the front side 

of the Braille page. Scanning should be done at 300DPI resolution. (A sample 

image with staple marks and ink marks is shown in APPENDIX figure – A1) 

Front side of the image can also be scanned but then ink marks if any should be 

manually removed from the image. 

→ Save the scanned Braille page on your computer in JPEG Format
i
 

→ Proceed to Next Step. (4.2) 

→ In case of a clean Braille sheet you can move on to step 4.3 

4.2 Edit the Braille Page using MS Paint 

→ Open MS Paint. 

→ Open the JPEG image that you saved in previous step. (4.1) 

→ Flip the image horizontally/ vertically depending on how image is scanned. 

→ Delete staple marks, ink marks on the image, if any using MS Paint eraser. 



→ Select any area on the image that does not contain blobs and copy it. 

→ Paste the copied area on the deleted area. 

→ Save the image. 

→ Proceed to Next Step. (4.3) 

4.3 Loading the Braille Page 

→ Open TransBraille. You will see a blank window as shown in figure 1. 

 
Figure - 1 

→ Click on File > Open. You will see a dialog box as shown in figure 2. 

 
Figure – 2 



 

→ Select “BrailleImage Files (*.jpg)” from the “Files of type” drop down box. 

→ Select the JPEG file saved in step 4.2.  

→ Click Open. 

→ The Braille image loads into the window. The window will appear as shown in figure-3. 

 

 
      Figure -3 

 

4.4 Converting into ASCII 

 

 

� At this point there are two options, either do step by step conversion or do direct conversion 

� In step by step conversion, select menu “Image > Convert to ASCII” or use the shortcut 

button on the toolbar as shown in Figure - 3 

� A warning message will be displayed. Click OK. 

� If the system is uncertain about a certain line, it asks you if the blob on a particular 

 line belongs to left column or right column.  

� Verify the same with the original Braille page and select either  

 “LEFT_COLUMN” or “RIGHT_COLUMN” 

� Press OK. 

� The dialog box is shown in figure 4 below. 

 



 
     Figure - 4 

 

� By following above steps ASCII file is opened in the document view as shown in Figure 5 

� For further translation  proceed to next step (4.5) 

� Otherwise to avoid going through intermediate steps manually, there is an option to convert 

input JPG file to PDF format. 

� To do it select menu “Image > Convert To PDF” or use shortcut button on the toolbar. 

� It will internally do all the intermediate stages and final output in PDF format will be shown 

 

4.5 Separating Math 

→ The window with Nemeth File will look like as shown in figure 5 below. 

 

 
Figure – 5 

→ There are two options given to user.  

These two options are 



1. Stepwise Conversion   

A.  Identification of Nemeth Math and literary Braille 

B. Translating delimited (identified) ASCII file to print math(PDF) 

2. Do complete conversion in one step. Here user need not bother about   identification of 

math. Identification is done internally. 

→ To do step wise conversion ,  

→ Select “Nemeth Translation >  Separate Math” from the Menu or select corresponding button 

on toolbar as shown in figure-5 

→ Select “Nemeth Translation > Show MathTag” from the Menu  

→ The Math Tag resembles a HTML Tag. A math expression is enclosed between <MATH> 

and </MATH> 

→ Double click the left mouse button to insert <MATH> and double click the right mouse 

button to insert </MATH> 

→ Once the desired changes are made to the Nemeth File, click on the “save” icon on the 

toolbar to save the file. 

→ Proceed to next step. (4.6) 

→ For Complete conversion in one step, select ‘Nemeth Translation > Convert ASCII to PDF’ 

It internally does the  math separation and generates the Latex file. Which is converted into 

PDF format and is opened in “acrobat reader”. 

Proceed to next step (4.7) 

4.6 Converting to LaTeX 

→ Click on the “Nemeth Translation > Convert separated ASCII to Latex” from the 

Menu   or corresponding button on toolbar as shown in figure-5 

→ Once the conversion is completed, a dialog box will popup asking if you would 

like to view the Latex file. 

→ Click “Yes” to view the latex file or “NO” if you do not wish to view the Latex 

file. 

→ After your selection, the latex document will be converted to a PDF document and 

is saved in the same folder as your Braille Image. 

→ Click ‘Yes” in the dialog box that appears to view the PDF output. 

→ Proceed to Next Step. (4.7) 

4.7 Printing PDF Document 

→ Now that you have viewed the PDF document, you may wish to print the 

document by clicking “File > Print” from the Menu. 

 

 

 

 

 

 

4.8 Other Features of TransBraille 

 



 
       Figure - 6    

 

1. Edit Image :  This feature opens jpg image in MS Paint and allows user to edit the 

image . To use this feature, select “Image > Edit image” or select corresponding 

button on the toolbar as shown in the figure - 6. Using MS Paint eraser user can 

edit jpg image. After editing the image save the file. 

 

 
      Figure - 7 

2. Show Blob Image : This feature shows the blob image to user. This is very 

helpful feature in the scenarios where input image is not very bright and it is 



difficult to recognize the dots.  To use this feature , select “Image > Show blob 

image” from menu or select corresponding button on the toolbar as shown in the 

figure – 6 Blob image will appear as shown in figure-8 

 

 
     Figure - 8 

 

3. Translate Contracted Braille: This feature allows user to evaluate the literary 

Braille. 

As shown in the following figure (figure -9) user can input contracted Braille in the 

text box named “Enter Literary Braille Text”. After pressing button “Translate” 

corresponding latex expression along with error message if any, is displayed. 

 

      Figure - 9 

 

 



4. Translate Nemeth Expression : This feature allows to evaluate nemeth 

expression.  

As shown in the following figure (figure - 10) user can input Nemeth Expression in 

the text box named “Enter a Nemeth Math Expression”. After pressing button 

“Translate” corresponding latex expression along with error message if any, is 

displayed. 

 

 
      Figure – 10 

 

5. Set environment : It allows to set the following environment parameters 

A. Image threshold : 

 

 
    Figure – 11 

 

 

 

 

As shown in figure 11, we can set four environment variables associated with Image 

threshold. 



1. Binarized Threshold : Gray scale ,depending on which pixel will be binarized. 

 

2. Blob Threshold :  Minimum number of continuous pixels for a blob to be 

considered as a Braille dot. 

 

3. Min Filter Threshold:  TBD 

 

4.   Max Filter Threshold:   TBD  

 

B. Image File name: It sets the output files names for the image processor.  

File name that can be changed are:  

1. Blobs file name  

2. Image filter file name 

3. Mark blobs  file name 

4. Warning file name 

5. Line Dimension file name 

6. Mark CHAR file name 

7. Mark DOTS file name 

8. ASCII file name 

9. BLOBS image file name 

10. Dots and text file name 

 

 

C. Nemeth FileName: This option is used to set the file names for  

      1. Error report file name 

      2. Log file name. 

 

It also asks whether to generate PDF file or not. 

    

 



 

5 APPENDIX 

5.1 Sample image showing staple marks and ink marks on a 
Braille page 

 
Figure – A1 



6 TroubleShooting  
 

� Scenario 1 : Nemeth file is opened and some changes are made to it and then 

the translator is called. But still changes are not reflected in the output file. 

Solution : It is very important to note that every time you make any change in 

any of the open files, that  file should be explicitly saved before using it as 

an input in any of the phases of the translation. 

 

� Scenario 2 : While converting to PDF a black screen comes  as shown in 

figure – 12 and nothing happens after this 

 

 
      Figure - 12 

Solution :  You will encounter this if there are some errors in the input ASCII 

file. On the black screen it shows the error it has encountered with line 

number. You can either manually go and edit the input file or just hit “Enter”  

If you hit “Enter” it will ignore this error and will resume to give the output. 

� Scenario 3 : Following error message can pop up 

 

 
     Figure - 13 

  Solution : Make sure that adobe acrobat reader is not open . If it is open then   

close it and rerun the translation. 



7 Frequently Asked Questions 
 

1. Do I need to install Aspell, prolog on my machine before using TransBraille? 

A.  You need to install Aspell on your machine but you need not install prolog. 

After you install Aspell, you need to add “C:\Program Files\Aspell\bin” to 

windows PATH. 

  

2. Do I need to install acrobat reader? 

A. Yes, you need to have adobe acrobat reader installed on your machine. 

 

3. What if the final output is not clear? 

A. In this scenario, do the following checks  

1. Check the blob image to find out if there is any problem in image 

recognition. If you see some problem, you can manually edit either image 

or ASCII file. 

2. If it looks like that image recognition is correct, check the Nemeth Math 

delimited ASCII file. If it looks like that some part is not separated 

perfectly you can add/remove delimiters manually. 

3. Check the error file and log file to find any specific reason of errors. 

4. After doing these checks you can re translate to Print Math format. 

5.  It may be possible that user input has typing mistakes. 

       

4. Some times it happens that nothing happens for many seconds.  

A. Be Patient!!!  Different modules such as image processing and math recognition 

do extensive checking / analysis so in some cases it may take up to few minutes 

to get the output. 

 

 

 

                                                 
 


